What to do if you are unable to deploy app and it appears the 0x89740005 error code

Yesterday it happened to me a strange think! Because I took some time to solve my problem I decided to share here my experience.

When I tried to deploy one of my applications on one of my Phone 7 device (that was unblocked some months ago), I received an error code 0x89740005.

Looking for the meaning of that code, I realized that is related to ”expiration of the device on App Hub“. So I went to AppHub to look at “My registered devices” … and I realized that effectively that phone was not present in the list. I was surprised but I thought “don’t warry!” … so I started the “Windows Phone Developer Registration” application to register that phone: the procedure seemed to be successful (see the following screenshot) but that error code continued to compare when I tried to deploy any application. I tried also to unregister / register again the phone, reboot it … with no success.

Then I found the solution in a forum where it is said that if a Phone is unblocked with one LiveId, it must be unregistered from the AppHub of that one before it can be registered with a different LiveId.
In fact, I remembered that many months ago that phone was unblocked by a collegue of me with his LiveId account and that it was why it didn’t compare in the “My registered devices” list of my account! 
I don’t know why the unblocking started to not to work anymore yesterday (perhaps I did an operating system update some time ago and after that I didn’t try to deploy any application on that phone), but when my collegue deregistered it with his LiveId account, I was able to make a really working unblocking from my account and then make the deploy of applications work again!!!

So problem solved also for me … even thought it is strange that one cannot really deregister and then unblock again his phone if it is not deregistered with the same LiveId account previously used to unblock it!! Moreover the message shown in the Windows Phone Developer Registration application is misleading because it says that “the phone has succesfully been registered” (and so it is unblocked) … while it is not (so it is not present in the  “My registered devices” list)!

Annunci

Informazioni su Enzo Contini

Electronic engineer
Questa voce è stata pubblicata in Windows Phone/Mobile e contrassegnata con , . Contrassegna il permalink.

Lascia un Commento/Leave a comment

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...